FatFractal customer forums



Recent Posts

Pages: [1] 2 3 ... 10
1
NoServer Questions and Answers / FatFractal aware dashboards
« Last post by admin@mandrel.com on August 09, 2017, 08:16:14 AM »
Has anyone pre-integrated any dashboard products with FF? We have data in FF and want to generate some simple reports on desktop/tablet/mobile and would prefer not to write or configure yet another dashboard that queries, summarises and renters data in tables/graphs. Ideally would like solution we can also host on FF, or is all javascript client based using FF API to recover data. Google search for FF and dashboard did not provide many hits.

2
NoServer Questions and Answers / Change directory path
« Last post by alex4pmi on May 09, 2017, 03:32:41 PM »
Hello,

I'm new to FatFractal. I'm trying to take over a project that someone was working on using FF.

We are trying to clean up code repo at the moment, because it was a bit of a mess, and it appears that I've done something that no longer reflects my changes on the development environment.

I basically changed the path to the code repo on the local environment and couldn't figure out how to tell the local environment to change the source of where the code should be. From what I gather, I believe issuing the command ffef deploylocal from the root path of where the code base is should deploy the code to the local environment's http engine. I did that and it didn't seem to take the changes that I made on the new repo. Now I can't seem to get the engine to look at changes made in the old source path either. I issued the same command on the root of the old repo.

Also I also issued the command ffef newapp applicationname domain as well on the new repo's directory, but that didn't seem to do anything.

I'm sure it's a mistake on my part but I can't seem to figure out a way to fix this. Please help.

Thanks.
3
NoServer Questions and Answers / EngineSecurityManager Error
« Last post by julio.bradford on March 04, 2016, 07:17:53 PM »
Getting the following error when call httpclient.request(); server side is nodejs and express with no require authetication.  I get about 10 error before the call succeed.

Regards

INFO | com.fatfractal.noserver.serverside.FF_JS_API$ScriptLogger | 2016.03.04 10 at 04:34:05.893 PM MST | ScheduledTask_ProcessAutoDataLoad | system | ymubO_-3GP-Af-evWSqTs6 | *** PMIRestfulWebService.getRequest.Request is [{"url":"http://pmi-coreos-bm04.dropsupplies.com:3000/companies","method":"GET","headers":{"Accept":"application/json","Content-Type":"application/json"}}]
ERROR | com.fatfractal.engine.security.EngineSecurityManager | 2016.03.04 10 at 04:34:06.222 PM MST | Security manager: Access denied for : checkPermission ([java.net.URLPermission http://pmi-coreos-bm04.dropsupplies.com:3000/companies GET:AcceptAccept-EncodingUser-Agent])
ERROR | STACK_TRACE | 2016.03.04 10 at 04:34:06.338 PM MST | java.lang.Exception
   at com.fatfractal.engine.security.EngineSecurityManager.checkPermission(EngineSecurityManager.java:295)
   at sun.net.www.protocol.http.HttpURLConnection.URLtoSocketPermission(HttpURLConnection.java:1034)
   at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1425)
   at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480)

code
      var url     = "http://pmi-coreos-bm04.dropsupplies.com:3000/companies";
      var headers = {"Accept" : "application/json", "Content-Type" : "application/json" }
      var request = {
         url: url,
         method: "GET",
         headers: headers
      };

      try {
         ff.logger.forceInfo ("*** PMIRestfulWebService.getRequest.Request is [" + JSON.stringify(request) + "]");
   var httpResponse = hc.request(request);
   var ccStatusCode = httpResponse.status;
   var ccResponse   = JSON.parse(httpResponse.content);

Nodejs code

var http = require('http'),
    express = require('express'),
    compression = require('compression'),
    morgan = require('morgan'),
    favicon = require('serve-favicon'),
    company = require('./routes/companies');

var app    = express();
app.use(compression());
var web400 = require('./server-web400');
var pm400  = require('./server-pm400');
var qs400  = require('./server-qs400');

app.get('/companies', company.findAll);
app.get('/companies/:id', company.findById);

app.listen(3000);
console.log('Listening on port 3000...');

node code example
4
NoServer Questions and Answers / Server-side code authentication
« Last post by metakite on January 19, 2016, 04:07:22 PM »
I'd like to authenticate an external website against the credentials I have stored in my FFUser table. To do that, I need to create an extension that receives a username and password and returns whether the username/password pair is valid. Are there any methods available in the Javascript server-side API that will allow me to determine if a provided password is valid for a given username without actually using those credentials to login? I looked around the docs, but couldn't find anything. I'm hoping I overlooked it.
5
I am converting my project from Objective-C to Swift and have run into a bit of a stumbling block with the objectFromDictionary method in that any attribute that is typed with an enum is not recognized by the method in the swift project, whereas the same approach works just fine in the objective-c version.  All other attributes of NSDate, String, Int, etc. are fine.

Does anyone know of a workaround/fix for this in swift?
6
NoServer Questions and Answers / Re: Loading BLOBs anonymously
« Last post by kwylez on October 07, 2015, 07:20:13 AM »
Thanks Gary...
7
NoServer Questions and Answers / Re: Loading BLOBs anonymously
« Last post by gkc on October 05, 2015, 06:22:13 PM »
Hi there,

Looks like a regression from a recent release. Will aim to fix tomorrow. It's not a permissions thing; just a bug in the data browser.

Apologies for the inconvenience
8
NoServer Questions and Answers / Loading BLOBs anonymously
« Last post by kwylez on October 04, 2015, 01:02:34 PM »
I uploaded a photo through the data browser (logged in), but I can't view it in the data browser if I'm logged out. The object itself is viewable whether or not I'm logged in.  I've tried setting
Code: [Select]
SET_PRIVATE AllowAnonymousGets true and
Code: [Select]
PERMIT read:public write:public ON /Photos and still no luck. Is there a default OAP for BLOBs?
9
NoServer Questions and Answers / Re: Connecting Locally through XCode
« Last post by gkc on October 04, 2015, 09:36:28 AM »
Hi there,

When testing against localhost, you will need to include this in the app's Info.plist

<key>NSAppTransportSecurity</key>
<dict>
   <key>NSAllowsArbitraryLoads</key>
   <true/>
</dict>

NB: This should not be in the Info.plist when submitting to App Store
10
NoServer Questions and Answers / Connecting Locally through XCode
« Last post by Rich on September 24, 2015, 09:14:38 PM »
We have been able to setup a local install of FatFractal and connect through the databrowser, we also have our iOS app connecting and running with our backend in the cloud.

However, we were wondering if there is anything special that needs to be done to connect to the local fatfractal install through XCode to run the iOS app.

We have our connection strings as:

static NSString *baseUrl = @"http://localhost:8080/<appName>";
static NSString *sslUrl = @"https://localhost:8443/<appName>";

We've tried adding:

[FFHttpDelegate addTrustedHost:@"localhost:8443/<appName>"];
[FFHttpDelegate addTrustedHost:@"localhost:8080/<appName>"];

And we get SSL errors when trying to login:

2015-09-24 19:57:59.644 Wryvals[9701:890404] Started (from main thread <NSThread: 0x7fc21d2012c0>{number = 1, name = main}) NSURLConnection for POST to https://localhost:8443/wyvalsAlpha/ff/login
2015-09-24 19:57:59.735 Wryvals[9701:890404] canAuthenticateAgainstProtectionSpace <NSURLProtectionSpace: 0x7fc21ae06f20>: Host:localhost, Server:https, Auth-Scheme:NSURLAuthenticationMethodServerTrust, Realm:(null), Port:8443, Proxy:NO, Proxy-Type:(null) called
2015-09-24 19:57:59.735 Wryvals[9701:890404] didReceiveAuthenticationChallenge <NSURLAuthenticationChallenge: 0x7fc21ae06f20> called
2015-09-24 19:57:59.735 Wryvals[9701:890404]          Challenge.protectionSpace.host == localhost
2015-09-24 19:57:59.735 Wryvals[9701:890404]          Host is a trusted host
2015-09-24 19:57:59.738 Wryvals[9701:890500] NSURLSession/NSURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9802)
2015-09-24 19:57:59.740 Wryvals[9701:890404] FFHttpDelegate calling onComplete for POST to https://localhost:8443/wyvalsAlpha/ff/login from main thread <NSThread: 0x7fc21d2012c0>{number = 1, name = main}
2015-09-24 19:57:59.741 Wryvals[9701:890404] HTTP POST failed: An SSL error has occurred and a secure connection to the server cannot be made. : statusCode 0
2015-09-24 19:57:59.742 Wryvals[9701:890404] Login failed: An SSL error has occurred and a secure connection to the server cannot be made.
2015-09-24 19:57:59.743 Wryvals[9701:890404] LoginWithUserName:(Passjjs) andPassword(Richard2) failed with error:(Error Domain=FatFractal Code=0 "An SSL error has occurred and a secure connection to the server cannot be made." UserInfo={NSLocalizedDescription=An SSL error has occurred and a secure connection to the server cannot be made.}).
2015-09-24 19:57:59.812 Wryvals[9701:890404] Login failed

Is there any way to disable the need to login through SSL?
Pages: [1] 2 3 ... 10
Copyright © FatFractal customer forums